IT Monkey:   Click Here to Help Me Build the Agenda for Upcoming Cireson Webinars!

Survey app not mapping work items to survey results / no reports

Ryan_EphgraveRyan_Ephgrave Customer IT Monkey ✭
I'm having some issues with the survey app. The first is work items don't seem to be mapping to surveys. I'm accessing surveys with this link:

https://PORTAL.com/View/SurveyApp#/mySurvey/?templateId=TEMPLATEGUIDE&workItemID=SCOBJECTGUID

and am able to fill out the survey. Once I hit submit, it successfully creates the CI, but the WorkItemID field on the survey CI is null. I created a view in the console to see the completed survey CIs and have verified WorkItemID is null and there are no related items on the new CI. I've also tried with the ID of a work item (IR2520) but that didn't work either.

I also can not see reports. When I go to Survey Templates and then hit the graph icon to open up a report, it switches to a report view but all I get is a spinning circle.  I know we need to wait a day for results, and some surveys have been submitted a week ago so I don't think that's the problem.

There was a post from someone else that said no reports could be a licensing issue. Could both of these problems be caused by licensing? We are licensed for the survey app, have the licensing app, and everything else (end user portal / helpdesk portal / knowledge base / dashboards) is working correctly. 

Thanks for any help!

Best Answer

Answers

  • Conner_WoodConner_Wood Customer Advanced IT Monkey ✭✭✭

    According to the Link WorkItem to Survey - Cireson KB#1318 Article, they have the link a bit different.

    http://localhost/View/SurveyApp#/survey/create?templateId=0441dc26-08f7-bc8b-4dba-25e9b385b33b&workItemId=$Context/?$Id$?

    Are you sending out the link to end users with the "/survey/create" portion?

  • Ryan_EphgraveRyan_Ephgrave Customer IT Monkey ✭
    Sorry about that, I tried many versions of the link and copied the wrong one.

    I tried that one also (to be sure, just tried it again) and a CI was created with WorkItemID null again.

    Though, what does this piece mean on the link:  $Context/?$Id$? - Is that simply the SC GUID of the work item, or is it looking for the work item ID (meaning IR10)?
  • Conner_WoodConner_Wood Customer Advanced IT Monkey ✭✭✭
    what does this piece mean on the link:  $Context/?$Id$??
    That's the code that would be used in the [SCSM Console >Administration > Notifications > Templates] that would be triggered and sent out to an end user, because you are instead using SCORCH you have the right idea of grabbing the "SC Object Guid" of the WorkItem and adding it to the link.

    It is possible the permissions/ have not replicated over, can you verify each step has been followed in the Survey App Installation Guide - Cireson KB#1307 

    Ex.  [SCSM Console > Library > Groups > Survey App Group] -- The Subgroups section contains the 3 groups:
    1. Survey Result Group
    2. Survey Report Group
    3. Survey Template Group

    You could try a full resync on your Cache Builder as well to ensure the CiresonDB isn't the culprit:
    Stop Portal - Stop Application Pool
    Stop Cache Builder then execute query.
    
    /** ULTIMATE CIRESON DB CACHE RESET */
    
    DELETE [ServiceManagement].[dbo].[DisplayString] WHERE ElementID IN (SELECT EnumerationID FROM [ServiceManagement].[dbo].[Enumeration] WHERE CreatedBy = 'c6745a66-5ccc-4fbc-b1d8-ab9797cdea2d');
    DELETE [ServiceManagement].[dbo].[Enumeration] WHERE CreatedBy = 'c6745a66-5ccc-4fbc-b1d8-ab9797cdea2d';
    
    TRUNCATE TABLE [ServiceManagement].[dbo].[Access_CI$User_ConfigurationItem];
    TRUNCATE TABLE [ServiceManagement].[dbo].[Access_CI$User_RequestOffering];
    TRUNCATE TABLE [ServiceManagement].[dbo].[Access_CI$User_ServiceOffering];
    TRUNCATE TABLE [ServiceManagement].[dbo].[Access_CI$User_WorkItem];
    
    TRUNCATE TABLE [ServiceManagement].[dbo].[Affected_CI$WorkItem_ConfigurationItem];
    TRUNCATE TABLE [ServiceManagement].[dbo].[Reviewer_WorkItem_CI$User];
    
    TRUNCATE TABLE [ServiceManagement].[dbo].[CI$DomainGroup];
    TRUNCATE TABLE [ServiceManagement].[dbo].[CI$User];
    TRUNCATE TABLE [ServiceManagement].[dbo].[RequestOffering];
    TRUNCATE TABLE [ServiceManagement].[dbo].[ServiceOffering];
    TRUNCATE TABLE [ServiceManagement].[dbo].[WorkItem];
    TRUNCATE TABLE [ServiceManagement].[dbo].[ConfigurationItem];
    
    TRUNCATE TABLE [ServiceManagement].[dbo].[Related_CI$WorkItem_ConfigurationItem];
    TRUNCATE TABLE [ServiceManagement].[dbo].[Relates_RequestOffering_KnowledgeArticle];
    TRUNCATE TABLE [ServiceManagement].[dbo].[Relates_ServiceOffering_KnowledgeArticle];
    
    TRUNCATE TABLE [ServiceManagement].[dbo].[LastModified];
    
    
    
    Optionally you can rebuild the database tables to free up space:
    
    USE [ServiceManagement];
    EXEC sp_MSforeachtable N'ALTER TABLE ? REBUILD;';
     
    
    Then Start Cache Builder
    Then Start Application Pool - Start Portal
    
    
  • Ryan_EphgraveRyan_Ephgrave Customer IT Monkey ✭
    I can now submit surveys for tickets. I think the issue was the account I was submitting the survey under wasn't the same account listed as affected user on the work item.

    I still can't see reports though. Through the Chrome developer tools, when I click Reports I get this error:

    VM2971:13236 TypeError: Cannot read property 'Content' of undefined
        at Object.convertChartistContent (services.js:696)
        at eval (controllers.js:412)
        at processQueue (eval at <anonymous> (jquery.min.js?v=723:3), <anonymous>:15552:28)
        at eval (eval at <anonymous> (jquery.min.js?v=723:3), <anonymous>:15568:27)
        at Scope.$eval (eval at <anonymous> (jquery.min.js?v=723:3), <anonymous>:16820:28)
        at Scope.$digest (eval at <anonymous> (jquery.min.js?v=723:3), <anonymous>:16636:31)
        at Scope.$apply (eval at <anonymous> (jquery.min.js?v=723:3), <anonymous>:16928:24)
        at done (eval at <anonymous> (jquery.min.js?v=723:3), <anonymous>:11266:47)
        at completeRequest (eval at <anonymous> (jquery.min.js?v=723:3), <anonymous>:11464:7)
        at XMLHttpRequest.requestLoaded (eval at <anonymous> (jquery.min.js?v=723:3), <anonymous>:11405:9)

    Any ideas?
  • Ryan_EphgraveRyan_Ephgrave Customer IT Monkey ✭
    Alright, after more investigating I've found that the "Cireson Survey Build Survey Reports" workflow fails after every run in SCSM. Does it have a log somewhere?
  • Conner_WoodConner_Wood Customer Advanced IT Monkey ✭✭✭
    edited September 2016
    Have you copied the DLLs from the "SurveyApp\_install\dll" folder over to the Primary Workflow Management Server?

    You need to put them in "C:\Program Files\Microsoft System Center 2012 R2\Service Manager" or wherever your install location is on your Primary Management Workflow Server.

    To find out which SCSM server is your Primary Workflow Server:

    1. Running this query against the ServiceManager database will return what the SDK Server (workflow management server) is:

      SELECT TOP 10 [BaseManagedEntityId]
        ,[DataService_98B2DDF9_D9FD_9297_85D3_FCF36F1D016B]
        ,[Server_48B308F9_CF0E_0F74_83E1_0AEB1B58E2FA]
      FROM [ServiceManager].[dbo].[MT_Microsoft$SystemCenter$ResourceAccessLayer$SdkResourceStore]

    2. Use SCSM Entity Explorer and search for Microsoft.SystemCenter.ResourceAccessLayer.SdkResourceStore and then go to the Objects Tab, Load objects and select the row and click View Details:

  • Ryan_EphgraveRyan_Ephgrave Customer IT Monkey ✭
    I first installed them on the primary management server, and then wound up throwing it on all of the management servers just in case. So the three dlls are there.
  • Conner_WoodConner_Wood Customer Advanced IT Monkey ✭✭✭
    Can you provide the details of the failed workflow instance?

    SCSM Console > Administration > Workflows > Status > Cireson Survey Build Survey Reports > Need Attention Tab > Find Failed Entry then View log > Select the failed event which was executing... There should be a details pane you can expand and copy text from.
  • Ryan_EphgraveRyan_Ephgrave Customer IT Monkey ✭
    I updated the Licensing app to the newest version. It grabbed the Survey App license key and the workflow started running.  Thanks!
  • Ryan_EphgraveRyan_Ephgrave Customer IT Monkey ✭
    So the mapping links work now (I thought they worked before but was wrong).

    Apparently the link is case sensitive. All my e-mail templates have:
    &workItemID=

    which doesn't work. I changed it to:
    &workItemId=

    I've tested it more than once this time! :smile:
  • Conner_WoodConner_Wood Customer Advanced IT Monkey ✭✭✭
    Yikes, Case Sensitive URLs are awful, congrats on spotting it, I seriously hope Cireson considers doing some improvements in the backend so the keys of the query string just need to match spelling, and not case.  Perhaps Cireson should mention on their article that you must type it exactly as it is case-sensitive at the moment.
Sign In or Register to comment.