IT Monkey:   Click Here to Help Me Build the Agenda for Upcoming Cireson Webinars!

Custom code that links directly to MAs getting "3 dots" forever on save

Jerry_VeldhuisJerry_Veldhuis Customer Advanced IT Monkey ✭✭✭

We have some custom code that links to an MA in a newly created tab, for the user to make changes to and upon hitting save, the tab is expected to close. This works fine except if the user makes changes, uses the 'apply', makes more changes then uses 'save', in which case the user is presented with "3 dots" flashing forever.

To reproduce, the steps are:
1) click on a link to open the SR in a new tab
2) make a change to a description field (really any change), hit apply
3) make a change to the description field (any change will do), hit save.

If (2) is not performed, it works as expected and the tab closes upon save.

I've been able to recreate with a rather simple html example. Links 1 and 2 I see the 3 dots forever, the 3rd link, which does not attempt to navigate directly to the activity tab works ok. But of course.. we'd prefer linking to the MA directly.

We are running 4.0.10, but I've also seen this same behavior in 6.0.

Here is the most basic example I could put together to reproduce what our app does, the html below can be placed in "testlink.html" in the CiresonPortal folder and opened in your browser ala (http://portal/testlink.html).

<html>
  <body>
    1st link to MA that does not work <a href="/Activity/Edit/MA50691/" target="newtab">MA50691</a>.<br>
    2nd link to MA that also fails<a href="/ServiceRequest/Edit/SR50686?activityId=MA50691&tab=activity" target="newtab">MA50691</a>.<br>
    3rd link to SR that works ok <a href="/ServiceRequest/Edit/SR50686" target="newtab">SR50686</a>.<br>
  </body>
</html>

Of course, you'll need to adjust the SR and MA#'s based on your env.

Appreciate any help you can provide.

jerry

Best Answer

Answers

  • Tony_CollettTony_Collett Cireson Support Super IT Monkey ✭✭✭✭✭
    edited September 2016
    So I recreated your issue with the first 2 examples that you provided. The 3rd worked only if I updated the SR, if I saved from the MA, it got stuck.  I was testing in version 6.0

    What the Save button does is try to send changes back to the server and then return to the page you were on before you saved the changes. 

    In your case, there is nowhere to go back because the work item is coming from a site the Cireson Portal doesn't recognise, therefore it gets stuck in a loop. I think this is only an issue with MAs.

    I'm going to have a chat with our developers to see if we can get this addressed. 
  • Kevin_BaierKevin_Baier Customer IT Monkey ✭

    Hey Tony


    This is not even at MA's.

    In the Notifications i have a link to the Workitem (like SR or anything)

    And my Analysts notified me that they were forwarded to a empty page.

    I think the best should be, that if there's no Site where the SAVE button can Redirect, it should use the Analyst/Enduser Start-Page which i can enter in the Portal Admin Settings.


    Best Regards

    Kevin

Sign In or Register to comment.