Home Analyst Portal

Cireson Portal Themer BETA Release!

2

Comments

  • Mark_WahlertMark_Wahlert Customer Advanced IT Monkey ✭✭✭
    I've had this before, the output file size for the CSS is 1.2bytes, and all it contains is the text David quoted. I currently can't export a proper CSS at all. I've logged a job previously but it started working again a couple days later.

    IE won't work because of @Leigh_Kilday post above, the colour pickers don't appear. 

    I find Firefox > Developer tools > Style Editor works well to preview but the 1MB CSS (when working) slows it down a lot.
  • Shayne_RayShayne_Ray Customer IT Monkey ✭
    "error evaluating function `lighten` The first argument to lighten must be a color (did you forgot commas?) index: 22252"

    Brand colour: #A4AEB5
    Link colour: #AA9C8F
  • Shayne_RayShayne_Ray Customer IT Monkey ✭
    edited December 2016

    Hey @james_kleinschnitz , tried this in Chrome and IE, same issue. Are you able to advise if there is a fix?

    Thanks.

  • Brett_MoffettBrett_Moffett Cireson PACE Super IT Monkey ✭✭✭✭✭
    Hi @Shayne_Ray
    Where are you getting this error?
    Ont he Themer page or on your portal once you have applied the CSS?
  • Shayne_RayShayne_Ray Customer IT Monkey ✭
    edited December 2016
    Hi @Shayne_Ray
    Where are you getting this error?
    Ont he Themer page or on your portal once you have applied the CSS?
    @brett_moffett When I download the css file, open it in notepad++ thats all thats inside it :neutral:

  • Brett_MoffettBrett_Moffett Cireson PACE Super IT Monkey ✭✭✭✭✭
    Try again in Incognito Mode.
    This strips out any cached issues or addins that might be interfering with the process.
    Try again and post back your results here.
  • Shayne_RayShayne_Ray Customer IT Monkey ✭
    Try again in Incognito Mode.
    This strips out any cached issues or addins that might be interfering with the process.
    Try again and post back your results here.
    @Brett_Moffett  Same message sadface
  • Brett_MoffettBrett_Moffett Cireson PACE Super IT Monkey ✭✭✭✭✭
    Is this using certain values that you have worked with the customer to organise? or are these just the default settings that are loaded when the page first loads?
    I just created a CSS file from the default page load and it worked fine.
    If you do have custom values that you are putting in, please send them to me and I'll try from my end.
    If not, try on a different PC or on a different network or both.
  • Shayne_RayShayne_Ray Customer IT Monkey ✭
    Is this using certain values that you have worked with the customer to organise? or are these just the default settings that are loaded when the page first loads?
    I just created a CSS file from the default page load and it worked fine.
    If you do have custom values that you are putting in, please send them to me and I'll try from my end.
    If not, try on a different PC or on a different network or both.
    Default colours download fine. 1.1MB

    Custom colours have been pasted above:

    Brand colour: #A4AEB5
    Link colour: #AA9C8F
  • james_kleinschnitzjames_kleinschnitz Cireson Dev, Product Owner Advanced IT Monkey ✭✭✭
    @Shayne_Ray I can reproduce this and will look into the issue.  Thanks for the feedback.
  • Brett_MoffettBrett_Moffett Cireson PACE Super IT Monkey ✭✭✭✭✭
    Hi @Shayne_Ray
    I just tried the values you suggested and I get the same result too.
    I also tried moving the values by one (Brand colour: #A4AEB6, Link colour: #AA9C8E) and it also returns the error.
    However, randomly picking a colour seems to work fine.

    It certainly seems to be a bug and I will leave it in the hands of the Dev team for a future fix.
    Please keep an eye on this thread for future updates.
  • james_kleinschnitzjames_kleinschnitz Cireson Dev, Product Owner Advanced IT Monkey ✭✭✭
    We have updated the Cireson Portal Themer with the ability to upload a previous theme and have your values restored.  Please give it a try and give us your feedback.

    http://portalthemer.cireson.com/

    We are also close to fixing the error caused by some color selections that a number of people have reported.

    Thanks
  • Dries_WerckxDries_Werckx Customer IT Monkey ✭
    edited April 2017
    Tool does not work with FF or Chrome. Always results in "Something went wrong please try again.".
    Values inputted: #DB3333 for Brand and Link color. Rest left as default (in FF re-entered all values).
    With the standard colour values, the css downloads perfectly.
    Also when trying to upload our custom.css file from Cireson v.5.0.7.0, the same error. (We are looking to upgrade to V7, hence the need for the adjusted CSS.)
    Please advice.


  • james_kleinschnitzjames_kleinschnitz Cireson Dev, Product Owner Advanced IT Monkey ✭✭✭
    I have fixed an issue that was caused by some link color values setting the hue to high.  If you have had issues in that past please try again and give us your feedback.

    http://portalthemer.cireson.com/

    @Dries_Werckx
    You can only upload previous themer output files, in order to restore your settings.

    Thanks
  • Dries_WerckxDries_Werckx Customer IT Monkey ✭
    That very much did the trick. Thank you!
    Another question, is there any way to get the original custom.css file (with the blue layout)? I changed a lot in the custom.css before trying the portal themer, and would like to implement on a clean sheet.
  • james_kleinschnitzjames_kleinschnitz Cireson Dev, Product Owner Advanced IT Monkey ✭✭✭
    edited April 2017
    @Dries_Werckx  with infinite number of ways to write CSS it is pretty much impossible for us to build a tool that could parse your css code and map your values to the values of themer.  
    You can however just include the themer file at the top of your custom.css so that your current changes will still apply.
  • Dries_WerckxDries_Werckx Customer IT Monkey ✭
    I did indeed do it that way and works like a charm. Thank you all for your replies.
  • Jarrett_FaulkJarrett_Faulk Customer IT Monkey ✭
    edited September 2017
    After adding the themer file to my implementation i've discovered that mult line items are displaying duplicate arrows as shown. This is present on My Requests, Team Work and Active Work. If i remove this file the issue does not exist.  
  • james_kleinschnitzjames_kleinschnitz Cireson Dev, Product Owner Advanced IT Monkey ✭✭✭
    @Jarrett_Faulk
    What version of the Portal are you running?
  • Jarrett_FaulkJarrett_Faulk Customer IT Monkey ✭
    edited September 2017
    james_kleinschnitz 
    We are running portal version 8.0.2016.7 with management pack 7.7.2016.185.
  • james_kleinschnitzjames_kleinschnitz Cireson Dev, Product Owner Advanced IT Monkey ✭✭✭
    @Jarrett_Faulk
    I am having our team update the themer for v8.x.
    I will let you know when it is ready.
  • james_kleinschnitzjames_kleinschnitz Cireson Dev, Product Owner Advanced IT Monkey ✭✭✭
    @Jarrett_Faulk
    We just updated the http://portalthemer.cireson.com/ please give it a try and see if it resolves your issues.

    Thanks
  • Jarrett_FaulkJarrett_Faulk Customer IT Monkey ✭
    @james_kleinschnitz
    I just created a new file from the portal themer and it appears that the arrow issue has been resolved.  Thank you and your team for the quick response.
  • Jonathan_BolesJonathan_Boles Customer Ninja IT Monkey ✭✭✭✭
    @james_kleinschnitz is the portal themer going to get updated for use with the Cireson Portal v9?
  • james_kleinschnitzjames_kleinschnitz Cireson Dev, Product Owner Advanced IT Monkey ✭✭✭
    @Jonathan_Boles I will do a QA cycle against 9.x+ and get the tool updated.
    Thanks
  • james_kleinschnitzjames_kleinschnitz Cireson Dev, Product Owner Advanced IT Monkey ✭✭✭
    The themer has been tested and updated for all the latest versions. 
  • John_LongJohn_Long Customer Adept IT Monkey ✭✭

    Hi @james_kleinschnitz , it seems the themer is adding duplicate dropdown arrows to selection lists!


  • Gabriel_LencesGabriel_Lences Customer Advanced IT Monkey ✭✭✭

    Can confirm this, we have the same issue on our side but we thought it was some other custom .ccs customization we added, thanks for pointing out that it's the Themer that's messing things up.

  • james_kleinschnitzjames_kleinschnitz Cireson Dev, Product Owner Advanced IT Monkey ✭✭✭

    I will get someone to look at this! -Thanks

  • Gabriel_LencesGabriel_Lences Customer Advanced IT Monkey ✭✭✭

    Thank James, if you or your teams finds a soluation to this, please let us know what lines to change in the file generated by the themer to get rid of the double dropdown, so we don't have to re-apply the whole thing again :)

    G.

Sign In or Register to comment.