We appreciate you taking the time to vote and add your suggestions to make our products awesome! Your request will be submitted to the community for review and inclusion into the backlog.

We recommend reviewing what is submitted before posting, in case your idea has already been submitted by another community member. If it has been submitted, vote for that existing feature request (by clicking the up arrow) to increase its opportunity of being added to Cireson solutions.

For more information around feature requests in the Cireson Community click here.

Send Email - 'Add message to action log' selected by default

David_AllenDavid_Allen Partner Advanced IT Monkey ✭✭✭
By default, when using the Send Email task for a work item, the 'Add message to action log' is not selected by default.  Please could we have an option to change this? 
We are finding many people are not selecting this option as it's so far down the page that you have to scroll to see it, which many analysts are not doing.  For us, we would always like to default to an option that records what was done.
26 votes

Submitted · Last Updated

Comments

  • Conner_WoodConner_Wood Customer Advanced IT Monkey ✭✭✭
    +1
  • Tom_HendricksTom_Hendricks Customer Ninja IT Monkey ✭✭✭✭
    Having this configured in the Admin Settings wouldn't be terrible, either.  Perhaps by work item type, but I would be fine with a single setting if that's easier.
  • Geoff_RossGeoff_Ross Cireson Consultant Super IT Monkey ✭✭✭✭✭
    Hi Guys,

    Maybe not the full feature you need but easily doable with the following. Place in custom.js (or another file and call from custom.js) and just copy and paste changing the work item type as needed,
    app.custom.formTasks.add('Incident', null, function (formObj, viewModel) {
        //bind a function to the form ready event
        formObj.boundReady(function () {
    		$(".link[data-bind*=sendEmail]").on("click", function () { 
    			$("#IsAddToLog").trigger("click").closest("div"); 
    		});
        });
    });

    Geoff
  • David_AllenDavid_Allen Partner Advanced IT Monkey ✭✭✭
    Thanks @Geoff_Ross

    I added the line "$("#IsAddToLog").trigger("click").closest("div");" to your MakeEmailToReadOnly solution and it works a treat.

    It would still be nice to keep this feature request alive though so hopefully it will become a feature that can be enabled or disabled in portal settings. 
  • Geoff_RossGeoff_Ross Cireson Consultant Super IT Monkey ✭✭✭✭✭
    Yup, no point in having all that code twice. And yes, agree, keep this feature alive.

    There's also a feature request covering a host of improvements to send email including this (in fact, I've just seen this same snippet on there).

    https://community.cireson.com/discussion/145/improvements-of-send-email#latest

    Its got quote a lot of votes, so go up-vote that too as it might make it in in the next 2 quarters at this rate.

    Geoff
  • JD_KeithJD_Keith Customer IT Monkey ✭
    Hey @Geoff_Ross, I placed your code snippet into our custom.js file, but the "Add Message To Action Log" button remains unchecked.  Is there something else that needs to be done?  Thanks for your help!
  • JD_KeithJD_Keith Customer IT Monkey ✭
    Update! @Geoff_Ross Forgive me, I noticed it worked in IE and Firefox, but only when I recycled IIS it started working in Chrome.  Thanks again for your code!
  • Geoff_RossGeoff_Ross Cireson Consultant Super IT Monkey ✭✭✭✭✭
    @JD_Keith
    You are welcome. Enjoy.
  • Conner_WoodConner_Wood Customer Advanced IT Monkey ✭✭✭
    Thanks to both @Geoff_Ross and @JD_Keith I too now have things working smoothly.

    I made 4 versions of that function for each ticket type that uses comments:
    • Incident
    • ChangeRequest
    • ServiceRequest
    • Problem
    Then in IIS I stopped the website, then stopped the app pool of website, then started app pool, then started website and it works in Chrome now.

    I would really, really like having this an "Out of Box" default, but if custom code must be used, so be it!
  • Sharon_SpearsSharon_Spears Customer Advanced IT Monkey ✭✭✭

    I've added the code to custom.js and its working for FF and Chrome, but IE11 won't play nice.

    Network Admin advised he has restarted the site.

    Suggestions appreciated.

  • Brian_WiestBrian_Wiest Customer Ninja IT Monkey ✭✭✭✭
    @Sharon_Spears
    Have you IE uses clear their local browser cache.
  • Marek_LefekMarek_Lefek Customer Adept IT Monkey ✭✭
    @Conner_Wood I do the same and it works. No IIS site or IIS pool is not were needed.
Sign In or Register to comment.