Home General Discussion

CIreson Console Licensing App: Can't copy dll to server

Rob_RRob_R Member IT Monkey ✭
Tried to upgrade our CIreson Console Licensing App and when copying the *workflows.dll file to the server, I keep getting the error message that the file is in use by another program. I've tried stopping the SCSM services and connections but doesn't seem to stop the file from being updated. Has anyone run into this before? And what am I missing? 


Best Answer


  • Brett_MoffettBrett_Moffett Cireson PACE Super IT Monkey ✭✭✭✭✭
    Have you stopped all three services plus the CiresonCacheBuilder service?
    This DLL is used by the console and should not require the cachebuilder service to be stopped.
    You may also need to make sure the console is closed and all users have their consoles closed on that are running locally on that server before the DLL file is released.

    If you find out what the combination is that is preventing you from copying it, please post it back here for others to see the solution that you came up with.

    I hope this answers your question.
  • Rob_RRob_R Member IT Monkey ✭
    Thanks @Joe_Burrows, Was able to figure it out and it was the Monitoring Agent that was locking the file. 
Sign In or Register to comment.