Issues installing DW on Windows Server 2016

Stuart_SneddonStuart_Sneddon Customer IT Monkey ✭
Anyone had any problems installing the SCSM 2016 DW server on Windows Server 2016?

I've got 

Answers

  • Stuart_SneddonStuart_Sneddon Customer IT Monkey ✭
    ... I'll continue here!!

    ... I've seen the following issues:

    DW GUI Install fails to find SSRS instances for the reporting server. SSRS is installed locally.
    This can be worked around by installing a SQL DB engine on the same server (for removal later).
    The next issue after this is the install GUI fails to find the Analysis services instances. This is a separate SQL Server.

    Both of these appear to be bypassed by using a silent install. However the install fails with an MSI error: 1603. The databases were created first before the MSI error!

    I've researched the MSI error, but nothing appears to work. Other MSI installers work fine.

    Have been able to replicate this at work and in a lab at home.

    Have no issue at all using the same setup package to install the Service Manager server and also using the same package on Windows Server 2012 R2 works without issue.

    Any thoughts?
  • Konstantin_Slavin-BoKonstantin_Slavin-Bo Customer Ninja IT Monkey ✭✭✭✭
    What SQL Server are you running? SCSM 2016 only supports SQL Server 2012 SP2 and later.
  • Stuart_SneddonStuart_Sneddon Customer IT Monkey ✭
    I've tried this with SQL 2012 SP2 and also SQL 2016 and get the same issue.
  • Marcus_EhrnellMarcus_Ehrnell Member IT Monkey ✭
    Hi Stuart,

    Have You checked the rights on the SQL-server? If I remember correctly I think I got the same error and the problem was the rights to add users in SQL-server database or similar.

    Regards

    Marcus
  • Stuart_SneddonStuart_Sneddon Customer IT Monkey ✭
    Hey @Marcus_Ehrnell , Yeah have the permissions to SQL, server etc. Got admin/sysadmin rights to everything.

    I was thinking it has to be something like this that I've missed, but it's strange that the 2012 R2 DW installer works with no issues using exactly the same, server, sql, accounts... everything. A 2012 - 2016 upgrade works fine too!

    We opened a case with MS, but curious that it doesn't appear to be a common issue!
  • Marcus_EhrnellMarcus_Ehrnell Member IT Monkey ✭
    Hi Stuart,

    Do you get any errors in the sql server log?

    Regards
    Marcus
  • Stuart_SneddonStuart_Sneddon Customer IT Monkey ✭
    Thanks @Marcus_Ehrnell  sorry for not getting back sooner.

    Microsoft support told us the RS problem is an issue with the 2016 installer and the product team are aware of it. This is where SSRS is installed on the DW server with the DBs residing on a separate SQL box. The workaround is to install the DB engine (then remove). Not sure if MS are going to fix this.

    It's also not unique to Windows Server 2016 as I suggested in the post title, happens on 2012 R2 also.

    Also isn't an issue in this configuration if upgrading from SCSM 2012 R2.

    The Analysis Services issue was actually related to our SQL Server. DB guys had to do apply some WMI fix.



    Cheers
    Stuart
Sign In or Register to comment.