Empty Queue When Workflow not Enabled

Nick_FlintNick_Flint Customer Adept IT Monkey ✭✭
At time (especially during development and testing) we will disable the Notify Analyst workflows to prevent certain e-mails from being sent out. However, it seems that these just pile up in a queue somewhere because as soon as we enable the workflow we get flooded with all of the past e-mail notifications. Is it possible to clear out whatever queue those notifications are lurking in so they aren't sent/received after the workflow is re-enabled. 

Another reason we want to do this is for the go-live of SCSM 2016. We're importing active Incidents from our old system and would like to suppress the emails from that process.

Best Answer

Answers

  • Adam_DzyackyAdam_Dzyacky Customer Contributor Monkey ✭✭✭✭✭
    Can't say I've ever looked, but I'd think that these jobs would simply be queuing within the Administration -> Workflows -> Status pane and from there you can cancel them. Assuming they queue here, this discussion highlights a C# and PowerShell way to cancel workflows en masse.
  • Adam_DzyackyAdam_Dzyacky Customer Contributor Monkey ✭✭✭✭✭
    Ha...or that. Appears I'm overthinking this.
  • Nick_FlintNick_Flint Customer Adept IT Monkey ✭✭
    Thank you, both!
Sign In or Register to comment.