Home Analyst Portal

Change Primary Owner scope on Incidents

Where can we change the source for the Primary Owner field on our incidents?  We would like to be able to have an AD group with analysts (nested group) & a few managers who are not analysts.

Best Answer

  • Joe_BurrowsJoe_Burrows Cireson Devops Super IT Monkey ✭✭✭✭✭
    Accepted Answer
    I will log this with support tomorrow; I think they helped us limit the box initially.  We have a large number of users, mostly students, so we try to filter every user box we can.  I will post the final fix here.
    if you set the filterbyanalyst flag to false it will show, I just tested earlier (see comment above)

Answers

  • Joe_BurrowsJoe_Burrows Cireson Devops Super IT Monkey ✭✭✭✭✭
    Hi Christopher

    If you want to have a primary owner set on default during creation you just need to set this in your templates. For request offerings you would need to do in each template the request offerings reference, and for the default new workitem portal forms you would need to create a new template and update the settingitems as below:

    1.       Find the display name of the template that you want to use in the SCSM console (Library\Templates)

    2.       Log in to a server that is running the SCSM management server and the Cireson Portal web site.

    3.       Start PowerShell

    4.       Run this command to load the SMLets PowerShell module:  Import-Module SMLets

    5.       Run this command to find the template name:  Get-SCSMObjectTemplate | ?{$_.DisplayName -eq 'the display name of the template'} | Format-Table Name, DisplayName

    6.       Copy the value from the Name column

    7.      Add the value to  settingitems in the admin settings for the template you want changes, eg DefaultIncidentTemplate 



  • Christopher_WisofskyChristopher_Wisofsky Customer IT Monkey ✭
    Thanks Joe, that's great info.  But I am trying to do something much simpler.  We are not to the point of needing automation of defaults.  Right now the Primary Owner field on our incidents in limited to 'Analysts' and we want to expand the choices available to 'Another AD Group'.
  • Joe_BurrowsJoe_Burrows Cireson Devops Super IT Monkey ✭✭✭✭✭
    Hi Chris

    You can set this FilterByAnalyst to false on your custom form for incident.js then you can pick any user or group:



    See KB for more details on custom forms

    Any questions let me know :)

    Cheers
    Joe
  • Christopher_WisofskyChristopher_Wisofsky Customer IT Monkey ✭
    I can see all the users in 'Affected User' but not in 'Primary Owner'.  So we have the groups and users in SCSM.  Somehow we've altered that field to limit the scope to analysts and need to get it back to the default of everyone, or better yet the 'managers' group I want to use.
  • Joe_BurrowsJoe_Burrows Cireson Devops Super IT Monkey ✭✭✭✭✭
    I can see all the users in 'Affected User' but not in 'Primary Owner'.  So we have the groups and users in SCSM.  Somehow we've altered that field to limit the scope to analysts and need to get it back to the default of everyone, or better yet the 'managers' group I want to use.
    Yep sorry spotted that after I commented, and changed my comment to the correct answer :)
  • Christopher_WisofskyChristopher_Wisofsky Customer IT Monkey ✭
    I will log this with support tomorrow; I think they helped us limit the box initially.  We have a large number of users, mostly students, so we try to filter every user box we can.  I will post the final fix here.
  • Joe_BurrowsJoe_Burrows Cireson Devops Super IT Monkey ✭✭✭✭✭
    Accepted Answer
    I will log this with support tomorrow; I think they helped us limit the box initially.  We have a large number of users, mostly students, so we try to filter every user box we can.  I will post the final fix here.
    if you set the filterbyanalyst flag to false it will show, I just tested earlier (see comment above)
  • Christopher_WisofskyChristopher_Wisofsky Customer IT Monkey ✭
    Thank You!  For anyone else with this issue, this flag was in our CustomSpace\Incident.js.  
Sign In or Register to comment.