Home Service Manager

Data Warehouse Extract Job not running on schedule

Mina_SaidiMina_Saidi Customer IT Monkey ✭


The data warehouse jobs all seem to run on their schedule besides the "extract" jobs. When i click on "resume" within service manager on that extract job it runs and works and everything is updated but otherwise the schedule doesn't trigger it.

the services are up and running but the extract jobs failed on the 24th of August 2019 and when i checked operations manager log on DW server i found the below error. How ever the errors are not happening at the moment but the extract jobs still wont run. the other jobs run and are successful.

SQL services are running, the connection between SQL database and DW is running, all the required permissions are there and im no longer getting any errors on ops manager but the it doesnt run unless i manually resume them.

anyone experience anything similar?

any ideas?

any help will be appreciated it.



  • Options
    James_AtanceJames_Atance Cireson Support Advanced IT Monkey ✭✭✭

    Have you tried stopping and starting the jobs via PowerShell? if not then below are the commands.

    Change the Computer name & Extract Job name to yours:


    Stop-SCDWJob -ComputerName SRVSCSMDW -JobName "Extract_DW_SM01"

    Stop-SCDWJob -ComputerName SRVSCSMDW -JobName "Extract_SCSM01"


    Start-SCDWJob -ComputerName SRVSCSMDW -JobName "Extract_DW_SM01"

    Start-SCDWJob -ComputerName SRVSCSMDW -JobName "Extract_SCSM01"

    These will show you more info on the jobs and will show were it is failing

    #View Job by Name

    Get-SCDWJob -ComputerName SRVSCSMDW -JobName "Extract_DW_SM01"

    Get-SCDWJob -ComputerName SRVSCSMDW -JobName "Extract_SCSM01"


    #View JobModule by Module

    Get-SCDWJobModule -ComputerName SRVSCSMDW -JobName "Extract_DW_SM01"

    Get-SCDWJobModule -ComputerName SRVSCSMDW -JobName "Extract_SCSM01"

    Hope it helps


  • Options
    Mina_SaidiMina_Saidi Customer IT Monkey ✭

    Thanks James, still an issue.

    have asked our BDA to investigate. its got me confused.

Sign In or Register to comment.