Home Analyst Portal

New Catalog Group - User unable to see Request Offerings and Service Offerings in Portal

T_R_Ash_McCan_1T_R_Ash_McCan_1 Member IT Monkey ✭

Hi all, I have created a new Catalog Group to limit certain user's views on the portal. I've selected everything I need, and made sure the user was part of the permissions chain, but the portal shows empty. I see the "Browse By Category" and "All Requests" headers, but there's no content. My main account, which has full access, is unaffected, so I'm assuming I'm working down the right path.

Quick high-level of what I did:

  • Created New Catalog Group, choosing the End User role
  • Note the Queues, Config Items, Catalog Items, Form Templates are all set to the "All" radio dial
  • I confirmed the new Catalog Group and Management Pack are visible in the Catalog Item Groups
  • For Users, I created a new Security Group, and my test user is a part of that group
  • Note That test user is only part of Domain Users and this Security Group.
  • I have left this change to bake in overnight, just in case it was a replication issue, but no dice.

Any thoughts or additional troubleshooting? Thank you all in advance.

Answers

  • donson_phamdonson_pham Member Adept IT Monkey ✭✭

    Hi @T_R_Ash_McCan_1

    In your Catalog Group, are you targeting the Service Offering level or request offering level?

    The portal only applies at the Server Offering level or category, just not the Request offering level. You can scope them in the 'Included' or 'Dynamic' members.

    Also, make sure the request offerings are indeed linked to the service offerings.

  • T_R_Ash_McCan_1T_R_Ash_McCan_1 Member IT Monkey ✭

    I actually had both - I took out everything except for one published Service Offering as an "Included" member. I tried your suggestion but am still getting the same result. Thanks for your help so far.

  • donson_phamdonson_pham Member Adept IT Monkey ✭✭

    That is odd.

    If you already restarted the cachebuilder and / or IIS, try clearing your browser cache... or open in incognito / private mode.

  • T_R_Ash_McCan_1T_R_Ash_McCan_1 Member IT Monkey ✭

    Yep, I restarted the services, and even rebooted the server, as well as tried incognito. I'm still exploring the configs in the event I set up something incorrectly.

Sign In or Register to comment.